Methods and non-static variables should be named in lowerCamelCase


The problem

The Google Java Style Guide ยง5.2 provides rules for naming nembers.

Test methods

The style guide includes the following special case for test methods:

Underscores may appear in JUnit test method names to separate logical components of the name, with each component written in lowerCamelCase, for example transferMoney_deductsFromSource.

Note that this only applies to test methods themselves, not to helper methods called by test methods.

public void transferMoney_deductsFromChecking() {

public void transferMoney_deductsFromSavings() {

// this method name shouldn't use underscores
private void transferMoney_deductsFromSource(Source source) { ... }

Instead of having a group of test methods call the same helper method with varying parameters, consider a parameterized test , or splitting the tests into separate setup and assert helper methods (named appropriately) to make the flow of each test clearer.


Suppress false positives by adding the suppression annotation @SuppressWarnings("MemberName") to the enclosing element.